Back
Maintenance

Maintenance

Completed 20 Nov at 01:05pm CET.

Tellucare Platform Tellucare Remote Supervision Tellucare Remote Patient Monitoring Tellucare Response Web
Completed

Maintenance completed

Posted 20 Nov at 01:05pm CET.
Started

Today between 12.30 and 14.30 we will upgrade the Tellucare authentication platform. There will be 5 to 15 minutes downtime. Tellu Support.

Posted 20 Nov at 12:30pm CET.