Back
Maintenance

Maintenance
Completed 23 Jan at 12:30pm CET.
Tellucare Platform
Tellucare Remote Supervision
Tellucare Remote Patient Monitoring
Tellucare Response Web
Completed
Maintenance completed
Posted
23 Jan at 12:30pm CET.

Started
Reminder: today between 12.00 and 14.00 we will upgrade the Tellucare authentication platform. There will be 5 to 15 minutes downtime. Tellu Support.
Posted
23 Jan at 12:00pm CET.