
Incident
Started 20 Feb at 10:56am CET, resolved 20 Feb at 01:03pm CET.
Resolved
TelluCare infrastructure is restored to full capacity and all services are operational again. The incident is not closed from Microsoft but it seems that there is no further impact on TelluCare.

Updated
Situation is improving and TelluCare is available again. However we do not have yet confirmation from Microsoft that the incident is resolved. Tellu Support.
Updated
TelluCare is down because of an Azure incident in Norway East datacenter. Latest message from Microsoft is "We are aware of this issue and are actively investigating. An update will be provided as events warrant.". On the Tellu side we are trying to mitigate the outage. At this stage we are unsure about how long the incident will be. We will post updates here as soon as we know more. Tellu Support.

Updated
TelluCare is unavailable due to an outage in the Microsoft Azure, Norway East Datacenter. Microsoft has confirmed the issue and we are monitoring closely. Tellu Support.

Created
TelluCare is affected by an Azure outage in the Norway East datacenter. We are monitoring the situation closely and have got confirmed from Microsoft that the incident is being handled. Tellu Support.