Back
Maintenance

Maintenance

Completed 2 Apr at 12:45pm CEST.

Tellucare Platform Tellucare Remote Supervision Tellucare Remote Patient Monitoring Tellucare Response Web
Completed

Maintenance completed

Posted 2 Apr at 12:45pm CEST.
Started

Reminder: today between 12.00 and 14.00 we will upgrade TelluCare. There will up to 30 minutes downtime. Tellu Support.

Posted 2 Apr at 12:00pm CEST.