Back
Maintenance

Authentication Platform Upgrade
Completed 2 Oct at 10:37am CEST.
Tellucare Platform
Tellucare Remote Supervision
Tellucare Remote Patient Monitoring
Tellucare Response Web
Completed
Maintenance is complete. Part of it is postponed to a later date.
Posted
2 Oct at 10:37am CEST.

Started
Reminder: today between 10.00 and 11.00 we will upgrade TelluCare authentication platform. There will up to 10 minutes downtime. Tellu Support.
Posted
2 Oct at 10:00am CEST.